Page 2 of 2 FirstFirst 12
Results 26 to 36 of 36

Thread: Neptune Systems Insiders (NSI) program launched

  1. #26
    New User
    Join Date
    Dec 2014
    Location
    Middletown MD
    Posts
    12
    Awesome idea! I submitted my Application. Hopefully you all can use me on some projects. And if you have any other questions please feel free to get in touch with me.

  2. #27
    Frequent Visitor rlauer's Avatar
    Join Date
    Jan 2016
    Location
    San Diego, California
    Posts
    87
    Not rocket scientist but would love to test new products as well since I will likely buy them anyway once they come to market... One can never have enough tech!

  3. #28
    Control Freak In Training
    Join Date
    Dec 2016
    Location
    West Unity, OH
    Posts
    74
    So now that I have received my Apex2016 how do I update my application?

  4. #29
    Frequent Visitor
    Join Date
    Mar 2015
    Location
    montana
    Posts
    68
    sent in my applications!

  5. #30
    Frequent Visitor
    Join Date
    Oct 2014
    Location
    South Florida
    Posts
    181
    Applied and hit submit which then said "processing" for 20 minutes, I then refreshed the page and it was a blank form. Not sure if it went through.

    Sent from my SM-N915T using Tapatalk

  6. #31
    Frequent Visitor
    Join Date
    Mar 2015
    Location
    montana
    Posts
    68
    Quote Originally Posted by Delmo View Post
    Applied and hit submit which then said "processing" for 20 minutes, I then refreshed the page and it was a blank form. Not sure if it went through.

    Sent from my SM-N915T using Tapatalk
    Exact same thing happened to me =(

    @Terence any way to see if you guys got our submissions?

  7. #32
    Frequent Visitor
    Join Date
    Nov 2013
    Location
    Long Island
    Posts
    152
    Thats because you didn't send Terrance his vig. 10% of your total system cost I believe... Just kidding.

  8. #33
    Frequent Visitor LobsterOfJustice's Avatar
    Join Date
    Jun 2013
    Location
    Cary, NC
    Posts
    791
    Submission page just hung for me as well...


    Sent from my iPhone using Tapatalk
    180g reef with all the bells and whistles

  9. #34
    Regular Vistor
    Join Date
    Jan 2017
    Location
    UK
    Posts
    16
    I've been trying to apply, but it seems to just get stuck "Processing...." when I submit my application?

  10. #35
    Frequent Visitor
    Join Date
    Oct 2014
    Location
    South Florida
    Posts
    181
    @Terence has anyone noticed this problem yet?

    Sent from my SM-N915T using Tapatalk

  11. #36
    VP Sales and Marketing Terence's Avatar
    Join Date
    Jan 2013
    Location
    Morgan Hill, CA
    Posts
    930
    Sorry guys, we have received many hundreds of applicants for NSI so at this time we have closed down the registration. We may open it back up at a later time. Look for an announcement here on the NS community forum if/when that happens.
    Terence Fugazzi :: VP Sales and Marketing :: Neptune Systems

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •